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Introduction  
You can share templates and custom objects that you create in ToolBook Instructor with content 
developers using ToolBook Assistant as well as other authors who use Instructor. Authors on your team 
can use the custom objects, catalogs, and templates that you build in Instructor to create more robust 
applications than they would otherwise be able to produce.  

By taking advantage of the techniques described in this document, you’ll be able to deliver custom 
resources and tools to other ToolBook users and enhance their authoring environment. Your resources 
can make the development of content in Assistant faster and more efficient. Also included is a description 
of how to deliver online documentation that will explain how to use your custom resources in the 
ToolBook environment. 

Creating Templates 
So that you can provide a consistent feature set and save time while building applications, Instructor and 
Assistant provide templates—prebuilt books that include page organization, graphic theme, interactive 
objects, and navigation controls. A template is ready for the addition of content.  

By delivering a template created in Instructor to Assistant authors or other Instructor authors, you allow 
them to take advantage of any objects with behavior you’ve assigned through the Actions Editor. 

There are several ways to develop a new template: 
• Open a blank book, add your own content and graphics, and then save the book as a template. You 

can open a blank book from the Quick Start tab of the ToolBook Instructor Startup dialog box and the 
New Book dialog box available from the File menu. 

• Open an existing template, modify it by adding or deleting objects and pages, and then save the book 
as a new template. You will find the templates that Instructor provides on the Templates tab of the 
ToolBook Instructor Startup dialog box that appears when you open Instructor and the New Book 
dialog box. 

• Create a book using the ToolBook Instructor Book Specialist and then save the book as a template. 
Following the prompts in the Book Specialist, you provide responses that Instructor uses to build a 
book to your specifications. After clicking the Build button in the Book Specialist, you can add objects 
or make modifications before you save the book as a template. You can open the Book Specialist (or 
the Quick Specialist, a streamlined version of the Book Specialist) from the Specialists tab of the 
ToolBook Instructor Startup dialog box and the New Book dialog box. 

?  To save a book as a template: 

1. From the File menu, choose Save As Template.  
2. Enter the template title, description, file name, and directory, and then click OK. 

After developing a template, you may want to provide guidance about the template to the course authors 
who will use the template to create applications. To describe the purpose of a page in a template or 
guidelines for its use, you can write descriptive text that will appear in the ToolBook Coach when the page 
is selected. For more information about assigning your own descriptive text, see “Adding Coach Text to 
Objects” later in this document.  

Preparing Templates for Internet Delivery 
If you are developing a template for learning applications that will be distributed over the Internet, 
include graphics that work well with the type of Internet connection that the learners are likely to have. 
A template for a book that will be distributed over the Internet to users with a high -bandwidth 
connection can include full-size backdrops and graphics with a large number of colors. When the 
typical learner has a low-bandwidth connection, use a tiled bitmap for the backdrop and limit the color 
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depth of your graphics to 256 colors to reduce the size and download time for the exported HTML 
files. 

The title that you assign to a template gives authors a clue about the delivery method for the 
template. When you prepare a template that is intended for delivery over the Internet via a high-
bandwidth connection, add these words at the end of your title: (HTML High Bandwidth). Set the title 
by choosing Properties for Book from the Object menu, and enter a name for the template on the 
General tab in the Book title box. Use the word (HTML) after the title of any templates which are 
intended for delivery over the Internet via a low-bandwidth connection.  

Delivering Custom Templates 
If the file size of a template is small, you can send it to other ToolBook authors as an e-mail 
attachment. Copy larger files to a shared network drive or an FTP site.  

Authors who receive a template file should place the file in the Template directory of the ToolBook 
Assistant program directory. That way, when they start Assistant or choose New from the File menu, 
the custom template you’ve created appears on the Templates tab of the ToolBook Assistant Startup 
dialog box and the New Book dialog box. The Templates tab displays a short description of each 
template to help authors to choose from among the offerings. Text describing your template will 
appear on this tab if you enter a book description on the General tab of the Properties for Book dialog 
box. 

Customizing the Catalog 
Presenting authors with a category of objects dedicated to a project or a specific corporate look can 
efficiently group together the components for creating new content. This section describes how to create 
a new category or catalog that you can deliver to other ToolBook authors. 

There are many ways to modify the categories shown in the Instructor Catalog.  

?  To modify the Instructor Catalog: 

• Right -click a category in the catalog and choose Customize Catalog from the menu. 

 

Figure 1: Customize Catalog dialog box 
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Creating and Exporting a Category 
One way to distribute custom objects to other ToolBook authors is to add them to a new category in 
the catalog. By exporting a category and sending it to other users, anyone can open the category by 
using the Import button shown in Figure 1. An example of a new category with custom objects is 
illustrated in Figure 2. 

 

Figure 2: Custom category named Corporate Objects  

?  To create a new category in the catalog: 

1. Right-click a category in the catalog. 
2. From the shortcut menu choose Customize Catalog. 

3. Click New. 
4. Enter a name for the category and other appropriate information. 

After you add a category, the next step is to place objects in this category. See the section titled 
“Adding Customized Objects to the Catalog” for detailed information. 

?  To export a category from the catalog: 

1. Right-click a category in the catalog. 

2. From the shortcut menu choose Customize Catalog. 
3. Click Export. 
4. Enter a name and location for this exported file (do not export to your existing Catalog folder). 

Before sending the exported category to ToolBook authors, you may want to reduce the size of the 
file by creating a zip file for the exported .wbk file. The people who receive your exported category 
can save the file in any location. When a ToolBook author clicks the Import button shown in Figure 1 
to locate your category file, it will be automatically installed in the proper location.  

You can deliver an exported category file by posting the file on a shared network drive or an FTP site, 
or by placing the file on a CD. 

Building a New Catalog 
A new catalog can contain any categories and objects you want. Providing ToolBook authors with a 
custom catalog is a handy way to focus their attention on selected categories, such as the ones 
needed for a particular project.  
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Authors choose which catalog to use by clicking the Object menu and choosing Properties for Book. 

 

Figure 3:  Catalog selection option 

If you deliver a custom catalog to ToolBook authors, be sure to tell them how to choose which catalog 
to use as shown in Figure 3. 

?  To create a new blank catalog: 

1. Right-click a category in the catalog. 
2. From the shortcut menu choose Customize Catalog. 

3. Click  
4. Enter the location for the new catalog (save it in a different folder from the Instructor Catalog). 
5. Add categories and objects to the new catalog. 

Before delivering a custom catalog to other ToolBook authors, create a .zip file that contains the 
folder with your custom catalog to reduce the file size. The .zip file can then be extracted on a local 
drive or a shared network location. Just make sure to tell the recipients of your custom catalog how to 
locate and access your catalog file. 

Adding Custom Objects to the Catalog  
A custom object can be as simple as a button in a corporate color. You can add any type of object that 
you have modified to the Instructor Catalog to make it easy to reuse.  

Often a custom object that you want to share with others will have some type of functionality that is not 
already available in the Instructor Catalog. You can use the Actions Editor to assign behavior to a button, 
for example, and then add this button to the Instructor Catalog. Another way to create a custom object is 
to group together several component objects, with behavior assigned to the group. 
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?  To add an object to the catalog: 

1. Select the object you want to add. 
2. Right -click a category in the catalog.  
3. From the shortcut menu choose Add Selected Object to Catalog. 

Example of a Customized Object 
One way to create a custom object is to start with an existing object from the Instructor Catalog. In the 
following example, new behavio r is added to the answer field for a fill-in-the-blank question. Entering 
an incorrect response to the question causes this field to turn red.  

 

Figure 4: Answer field turns red when response is incorrect 

This red indicator for an incorrect answer replaces the default setting for immediate feedback. There 
are just a few steps necessary to modify the default behavior. First, open the properties for the fill-in-
the-blank question and clear the check box shown below: “Enable feedback at time of response.” 
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Next, assign the color red to the answer field if the fill -in-the-blank question is not answered correctly. 
Select the answer field, open the Actions Editor, and choose the “On question answered” event 
shown in Figure 5. 

 

Figure 5: Color of the answer field changes if a user enters the wrong answer 

The action sequence shown in Figure 5 causes the answer field to turn red immediately after an 
incorrect answer is entered (when the user presses the Enter key, Tab key, or moves the focus to 
another object). To return this red field to the original white color each time the question is reset, 
choose the “On reset” event and set the color as illustrated in Figure 6.  

 

Figure 6: Fill color of the answer field turns white when question is reset 

Saving the actions shown above will complete the task of modifying the fill-in-the-blank question. Now 
it could be added to a category in any catalog along with an explanation of how to use it. A 
convenient way to provide a description of an object is to assign text that will appear in the Coach 
window, as described in the next section.  

Adding Coach Text to Objects 
The ToolBook Coach is a convenient reference tool that provides context-sensitive information as you’re 
authoring. For any object you select, the Coach displays guidance by providing a description and step -by-
step procedures. It is included with Instructor and Assistant.  
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?  To open the Coach: 

• Click the Help menu and choose Coach. 

 

Figure 7: Coach shows a description and steps  

You can write your own Coach text to accompany custom catalog objects. This custom Coach text will 
help Assistant authors to include the objects that you create using Instructor in their own applications. In 
addition, by following the techniques we’ll explore in this section, you can change the existing Coach text 
for any catalog object. 

Using the Property Browser in Instructor, you can assign text that will appear in both the Coach and in the 
pop-up description box that appears when the user points at an object in the catalog.  

?  To assign descriptive Coach text to a custom object: 

1. Select the object to which you want to assign Coach text. 
2. From the View menu, point to Browsers, and then choose Property. 
3. In the Property Browser click the User tab.  
4. In the Name column look for the INFO_Description property. Do one of the following: 

• If the INFO_Description property exists, double-click the name of this property to open the Edit 
Property dialog box. Enter the description for this object as it will appear in the Coach, and then 
click OK. Note that changing the value for the INFO_Description property will overwrite the 
existing Coach text for this individual object. If you add this object to a catalog, your Coach text 
will appear whenever the object is selected.  

• If the property does not exist, scroll to the bottom of the list. Double-click the <Add New> link. 
Under Property name, type INFO_Description. Under Property value, enter your Coach description 
for this object. 

5. Close the Property Browser. 
6. To view the description you wrote, be sure the appropriate object is selected and look in the Coach 

window. 
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Quick Steps appear below the description of an object in the Coach. Using a procedure like the one 
above, you can assign text for either the INFO_BasicStepsText or INFO_AdvancedStepsText properties 
in the Property Browser. The names of these user properties refer to Basic mode and Advanced mode—
the two authoring levels in Assistant. When Assistant is open in Basic mode, the steps assigned to the 
INFO_BasicStepsText property appear in the Coach. In Advanced mode, the steps assigned to the 
INFO_AdvancedStepsText property appear in the Coach.  

Creating New Options for the Quick Specialist  
If an author plans to build a book with multiple sections of repeated pages, using one of the Book 
Specialists can be faster than starting a book from a template. Book Specialists are a type of wizard that 
prompts an author for information. ToolBook uses this input to build a book based on the author’s 
specifications.  

The Quick Specialist is one of the Book Specialists available when you open ToolBook. The following 
information about creating options for Quick Specialist also applies to the Full Specialist and Lesson 
Specialist also.  

 

Figure 8: Quick Specialist provides choices for building a new book 

In this section, you will learn how to make new pages available through the Quick Specialist to allow 
ToolBook authors to access the custom page designs that you have created. After you design custom 
pages in Instructor and deliver them to other ToolBook authors, these pages are visible when using the 
Quick Specialist, as shown in Figure 7.  
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Figure 9: List of available page styles 

To make your own custom pages available in the Quick Specialist, first build a new page style book in 
ToolBook. A page style book contains uniquely named pages that you design; it is the source book from 
which ToolBook authors will choose individual pages in the Quick Specialist. On the pages of this book 
you can include objects from the catalog, navigation controls, backdrop graphics and any features that 
you want authors to have at the ready.  

When creating a new page style book: 
• Create a new background for each page. 

• Assign each background a unique name by selecting Properties for Background from the Object 
menu and entering a name in the Name field.  

• Each page must have the same name as its background. Assign a page name by selecting 
Properties for Page from the Object menu and entering a name in the Name field.  

• Save the file with a .ptp file extension. 

When you have finished designing your book of custom pages, assign a title for your page style that will 
appear in the Quick Specialist on the Page Style page.  

?  To enter a title for a page style that will appear in the Book Specialist: 

1. From the View menu, point to Browsers, and then choose Property. 

2. In the Property Browser, select Current Book. 
3. Click the User tab. In the Name list, look for the INFO_Title property. Do one of the following: 

• If the INFO_Title property appears, double-click the property name. Enter two or three words to 
describe this page style book. 

• If the property does not exist, scroll to the bottom of the list and double-click the <Add New> link. 
Under Property name, type INFO_Title. Under Property value, enter a title of two or three words 
that describe this page style book. 
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4. Click OK and then close the Property Browser. 

When you choose the HTML option on the Distribution Method page of the Quick Specialist, you’ll notice 
that the page style titles that appear on the Page Style page are followed by (Internet) or (Internet High 
Quality). These page styles are drawn from source books that are optimized for delivery over the Internet 
via a low-bandwidth connection or high-bandwidth connection, respectively. If you develop page styles for 
distribution over the Internet, append (Internet) or (Internet High Quality) to the page style title you enter 
as a value for the Info_Title property.  

In order for the Book Specialist to recognize your page style book and display the name you’ve entered, 
save this ToolBook file with a .ptp file extension and place the book in the Spclst\Styles directory of the 
ToolBook Instructor program directory.  

Creating a New Outline File 
After you select a page style in the Quick Specialist, the next step is to choose an outline for the types 
of pages that will appear in the book that will be created by the Quick Specialist. You can select one 
of the existing outlines or choose the Custom link at the end of the Defined book outlines list to 
choose pages. If you want to provide others with a different outline, you can create a new outline file. 

 

Figure 10: A book outline displays the names of individual pages 

An outline file allows the Quick Specialist to recognize the individual pages in your page style book. 
The names of these pages appear in the Book Outline list shown in Figure 8. 

You can create an outline file in any text editor that can save a file in a simple text format, such as 
WordPad. An outline file is a text file saved with an .aof extension as shown in Figure 9. 
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Figure 11: Example of an AOF file 

A fast way to create your own outline is to open an existing .aof file from the \Spclst\Outlines folder of 
your Instructor program directory and save the file with a different name. Replace the text that 
appears to the right of an equal sign (=) with your own information, as described in the table below. 

 

Item in outline file Description 

Name The name you enter appears on the Book Outline 
page under Defined book outlines (see Figure 8). 

Type Enter the word Complete.  

Description 

 

The description appears on the Book Outline page 
when this outline is selected.  

Sections Enter the name of each background in your page 

style book, with each name separated by a comma.  

 

The outline that appears in the Quick Specialist can contain repeating sets of pages, illustrated in 
Figure 6. If you want to include repeating sets of pages, in the outline file designate the number of 
times the section should be repeated. For example, the following line copies a page named 
Interaction ten times:  

Sections=Introduction,[repeat 10 times],Interaction,[end repeat section],Summary 

A section that is repeated will be displayed to the user in blue text as shown in Figure 10. 
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Figure 12: Book outline with repeated set of pages shown in blue text 

A book outline file allows the Quick Specialist to recognize the individual pages in a page style file. You 
can take a look at a custom page style file with a .ptp extension and an outline file by following the steps 
in the next section.  

Installing a Sample Page Style Book and Outline 
As an example of using custom styles in the Quick Specialist, you can download a .zip file that contains a 
custom page style file and outline file from this location: 
http://www.toolbook.com/documents/ToolBookSP2_800x600i.zip 

 

After you download the .zip file, extract the contents and copy the files to your ToolBook folders which 
store these types of files. Place the file named ToolBook SP2 800 x 600i.ptp in this ToolBook folder: 

   C:\Program Files\SumTotal\Instructor 2004\Spclst\Styles 

Place the file named SP2.aol file from the downloaded .zip file in this folder: 

   C:\Program Files\SumTotal\Instructor 2004\Spclst\Outlines 

?  To view the example page style and outline:  

1. Open ToolBook Instructor. 
2. Click the Quick Start tab in the Startup dialog box. 
3. Double-click the Quick Specialist icon. 
4. When the Quick Specialist opens, click Next. 
5. Enter information in the General Information fields, and then click Next. 
6. In the list of page styles, choose ToolBook Sp2 800x600 (HTML).  
7. Click Next. 

8. Click Yes when prompted to confirm the deployment method, and then click Next. 
9. Click the Build Your Template button. 


